Freeze on startup


#1

I’m using Balsamiq 3 for desktops. I tried to open a BMPR file that I believe may have been corrupt in some way - (I suspect it was a victim of a CR/CRLF swap.) It caused Balsamiq to become essentially unresponsive. I terminated the process (and even tried rebooting) but now when I double-click the Balsamiq application icon, it looks like Balsamiq is trying to find and open that mockup at startup, which is causing it to go unresponsive again.

I don’t know where that offending BMPR file resides or I would just delete it (the corrupt file was originally opened by my git client software and I don’t know where it has that file stashed.)

Can I force Balsamiq to start with an empty mockup rather than trying to reload the last file?


#2

I just solved my own problem. Posting the answer here in case someone else has the problem in the future. I had even tried uninstalling Balsamiq and AIR and re-installing but the problem was still there (Balsamiq was still remembering the bad file.)

Solution:

  1. From the windows command line, change directory to %AppData%
  2. Remove the Balsamiq folders (there were two for me)

This may have removed some minor preference info like “recent” files but at least Balsamiq is back online for me now.


#3

Hi @bbeswick

Thanks for taking the time to explain the issue and how you solved it.

The approch you choose is currently the only one to force balsamiq mockups 3 to forgett which projects were open in the last session.
We shipped today a new release that has a change that prevents the application to hang in one scenario that we identified.

You can get the latest version (3.1.5) here:
https://balsamiq.com/download/