"Full-Screen Presentation" mode displays everything starting at the very-very top of the screen

Okay, this may end up being the most insipid forum topic ever (< grin >), but I’m wondering if this irritates anyone else. I often find myself needing to screencap the contents (full or partial) of a wireframe (to drop into the body of an email, onto a presentation, etc.) A PDF export is not always the most appropriate vehicle for this, and if the objects exceed the scrolling area, I will use “presentation mode” to get the whole thing on-screen so I can screen-cap it.
No matter where on the page I place the objects, Balsamiq will render from the absolute top of the screen - not a single pixel down, in full-screen mode. Meaning my mouse skills have to be superhuman not to catch a row or two of the top border along with the image:

I’ve developed a hack (awkward as it is…) for this. Add a white-on-white rectangle or some other object above the rest to act as vertical padding during the full-screen rendering.

Anyone else faced this? Solved it? Or is this a case of “c’mon, export the PDF and put it wherever you want.” (Great - ever tried placing a PDF in-line in an email, when Outlook insists it must be an attachment?) So many extra clicks to circumvent all of that.

// “Lazy” Steven…

I’m sorry about this @Steven_Swinkels.

The good news is that this isn’t the intended behavior - it’s a side effect of the combination of our Full Screen algorithm and the varying sizes of your wireframes.

Because Full Screen mode prioritizes keeping your wireframes stationary relative to each other, it adjusts the view based on the largest wireframe in your project. We do this so that the wireframes don’t jump all over the place when you’re presenting.

If you have small and large wireframes, the small wireframes get shoved up against the top of the canvas because that way, they are “framed” the same way as your large wireframes.

What you can do is adjust the Full Screen centering to ignore the large wireframes when centering.


For example, in this image, if you uncheck the Tall and Wide wireframes, the rest of the project will render in the center of the screen. Things will jump a little when you see the tall and wide wireframes, but the rest of the project will be centered.

Let me know if that makes sense, Steven, and if it helps. I’m sorry again for the trouble here.

Thanks, Brendan - that certainly did the trick. Would be great if I didn’t have to customize per project, but I can see from the design that it’s obvious you really can’t set something like that globally (not knowing how ridiculously-tall and skinny I might make a particular wireframe).
But this absolutely does the job- many thanks.

1 Like