Balsamiq Community Discussion

"icon_" png assets are no longer seen as icons?


I used to add my customs icons (square png files) prefixing their name with “icon_” and adding them as assets to my project.

I have recently upgrade to Balsamiq Mockups 3.5.5 and my “icon_” assets

  • Are no longer seen as icons but are seen as images when I add them to my mockups. I have to “transform to” icon these images
  • Are no longer accessible in “Quick Add” using their name without the “icon_” prefix: The name is “icon_my icon” instead of “my icon”.

Could there be a regression in recent versions of Balsamiq Mockups?



Hi @cleclerc,

You’re right, we’ve just changed this in a very recent version to make it easier. You can now pick any of your image assets as an icon now without having to use the “icon_” prefix.

All you need to do now to use an image as icon is to:

  1. Add the image asset to your project
  2. Add an Icon control and select your image from the bottom category named “Assets” of the icon library

We hope this works well for you, please let us know if you need anything else! :slight_smile:


Thanks virgin,

I was suspecting this evolution seeing in the docs that the prefix “icon_” disappeared.

Unfortunately, I have a challenge with this new behavior: when using “quick add”, the png that I want to add to my mockups as sizeable icons are inserted as “image” and thus don’t have the size xs/s/m/l/xl/xxl option.

I have to first “transform to” my png from “image” to “icon”.

It’s not a blocker but I would love to have the capability to specify that some of my png assets should have the size xs/s/m/l/xl/xxl option when added in my mockups.


Good point, @cleclerc. Sorry for the hassle with this.

I’ll bring this topic to the team and we’ll discuss it further to see if we can think of a better behavior. In the meantime, the easiest way to achieve this is either your suggested way or adding an icon and choosing the asset from the icon search/library.

The latter can be pretty quick if you know the name of your asset already:

Hope this helps in the meantime! Thanks for bringing this to our attention. :slight_smile: