Image not found after Mockup3 import


#1

I’m working with Mockup3 on severall projects, but wanted to share them with partners and customers so they could help me.

So I created a Trial Account on Mybalsamiq and imported my 2 projects, but I’m having problems.

For the first one, MyBalsamiq seem to be freezed as it does not create the pictures, and I’m not able to edit the mockups.
For the second one, everything went fine during import, I’m able to edit it, but most of the images I had (on my buttons etc.) are missing. What’s very strange is that the images I added manually to Mockup3 are there, but the one I used coming from Mockup3 are not there…

Thank you very much for your kind assistance on this


#2

Hey @m_blass,

The issue you are running in to is a side effect to the stuff we added in Mockups 3 (namely, the Font Awesome icon library http://fortawesome.github.io/Font-Awesome/) that hasn’t make it to myBalsamiq yet. We are working hard to bring the two into parity, but it’s a large project and we are a small team.

We do have some work arounds, though.

We have a FAQ on how you can try to make your project more myBalsamiq friendly here: http://help.balsamiq.com/mybandb3d but that has a lot of limitations, unfortunately.

A better solution may be to have your clients install Mockups 3 ( https://balsamiq.com/download/ ) and then you can send them the BMPR file directly. They will be able to open files even after the trial expires.

The third (coolest but most complex) workaround is to use the webdemo we have on the homepage (http://webdemo.balsamiq.com/). You can create one specifically for you by adding ?pid=m_bass to the url (IE http://webdemo.balsamiq.com/?pid=m_bass - you can change m_bass to whatever you would like) upload the project to there, and then share it with your customers. The webdemo is built on top of the tech that we added in Mockups 3 (and will eventually make it to myBalsamiq) so there shouldn’t be any compatibility issues. It can even be used for real time collaboration. There is one caveat, however, and that’s the project will self destruct after an hour, so make sure that you budget time accordingly.

Let me know if any of those work for you, and if you have any other questions :smile:

Happy Wireframing!


#3

H Brendan,

Thank you for explanation. So in the meantime I use another icon libreary that I have, by importing icons manually as assets in Mockup3.
I tested and it worked nicelly. Then I continued to work with Mockup3 and tried to import once again my work, but now I get this error message

“Invalid anti csrf token !!!”

What could I be doing wrong?

Thanks for your help again
Bless


#4

You aren’t doing anything wrong, my friend. That’s just a side effect of a new security measure that we implemented in myBalsamiq last week. Refreshing the page should clear it.

Let me know if that clears things up for you. If it doesn’t, shoot me an email at support@balsamiq.com and we will dig deeper!


#5

Hi Brendan,

Indeed, just a refresh from browser solved my problem.

Thank you very much

Looking forward having all nice icons in the web interface as well :wink:

Bye