Import BMML Mockups into a BPMR Project isn't working correctly


#1

I tried to import 7 BMML files into a new project in Mockup 3.0.3. The import ran successfully, as in I didn’t receive any errors, and all of the files were created, but they were empty. When I tried to open one of the imported files, it was just a blank screen. I tried saving the BPMR file, and reopened it to see if it would open the old BMML files, but they were still blank.

I believe there was something corrupt about the BMML files that I was attempting to import. I had gotten these files from a back-up, when I got new versions of the files and I was able to import them correctly. Please remove this issue. Thanks!


#2

Hi @jray , sorry for the trouble! If I’m understanding you properly, it’s working correctly now for you. Is that right?

When you say that you had gotten the files from a back-up, what exactly do you mean? How were the files recovered, or where was the back-up? This is not a problem that we have seen before, and would love to get it fixed. Thanks for letting us know about it!


#3

Thanks for the response. I lost my hard-drive last week and had to get a new one. I had backup my old hard-drive (including the BMML files) before the crash using a backup application called Back-Blaze.
When I got my new hard-drive I did a fresh install of Balsamiq, which got me to version 3.0.3.
I restored all of the files (including the BMML files) from my old hard-drive on to the new one, and these were the files that I attempted to upload into the new version on Balsamiq. The upload didn’t work correctly, which is why I created the ticket.

I had emailed the BMML files to a coworker a few weeks ago, so I downloaded them from the sent email, and I attempted to upload these new files into Balsamiq, and it worked correctly. So the issue must be with the BMML files that I restored from my old hard drive. I imagine that it has more to do with the backing up/restoring of the files than the import to Balsamiq.


#4

Gotcha. That makes a lot of sense. Thanks for the additional details! And sorry you had to go through that! What a mess! :confounded: