Balsamiq Community Discussion

Impossible to change mockups order in Mac


#1

Hello,

It’s not possible to change the order of mockups by draging them which is very very anoying when the project is big, was the same in the version from january that i had, i just updated to the 3.5.3 and the bug is still there.

Hope you can fix it soon, thank you !

Florent


#2

Hi @Florent,

Sorry for the hassle with this.

We discovered this bug when OS X Sierra was released but our latest version 3.5.3 should have the fix for it so I am really surprised that you still see it.

Is your Mac running the latest OS version?

If the issue persists, could you please record a screencast of the issue and share it via support@balsamiq.com?

We’ll do our best to help!


#3

Hello,

I have OS X Yosemite 10.10.

The issues persists, i tried every way that doesn’t works.

We does the new update arrive on the market?

Thank you.

Florent


#4

Hey @Florent,

I’m really sorry for the trouble here. Are you able to drag anything onto the canvas?

Try dragging something from the UI library, or dragging an image onto your canvas. It’s possible that you have hit a super rare bug and this is the way we can confirm it.

I’m sorry again for the trouble, my friend. Let’s see if we can figure it out. :slight_smile:


#5

Hi Brendan,

You’r right i can’t drag nothing, to add something from the library i have to double clic it.

I also tried the interface where the mockups appears as a screenshot but there neither i can drag them.

Thanks for your help :slight_smile:


#6

Would you mind trying one more thing for me, Florent?

Try doing the same actions on our web demo and see if they are broken there too.

Thank you for sticking with us on this, Florent.


#7

Hi Brendan,

Sorry i didn’t see your answer, i just tried on the web version and it’s working fine, i can drag and drop mockups.


#8

Thanks for the update, @Florent.

Another question:
Are you using an Apple mouse or any different one?
Do you have any custom mouse driver or specific configuration maybe?

Thanks for your patience.


#9

No it’s just the pad of a MacBook Air 11" with the basic configuration.


#10

What a weird one, @Florent!

Would you be available anytime soon for a video call so we can go through this together? Tomorrow maybe?

Please let me know about your preferred date and time via support@balsamiq.com and we’ll set it up!

Sorry again for the trouble with this.


#11

Hello, we i can share my screen through Skype if you want but not really sure that help you no? I mean it’s just doesn’t work so will you able to get more informations by seeing this in video?

Thanks.
Florent


#12

Hi @Florent,

We were thinking of trying a few other steps, like a proper re-install, but you might have tried that already? Anyways, we are happy to set up a call over Skype or GH but that’s totally fine if you prefer to run steps on your own too. :slight_smile:


#13

Yes i already re-install and updated for the last version but without results. Thanks for you help, just let me know the few things i can try and i will do by myself and let you know the results :slight_smile:


#14

Hey @Florent,

Here are a couple things to try:

  • Do you have an external mouse/trackpad to try?
  • Do you plan on updating to the latest OS X (Sierra) by any chance?

If we cannot figure this out, we’ll be happy to find an alternative solution for you (maybe another version of our tool). We want you to be able to use Mockups and all its feature. Please reply via support@balsamiq.com with the results and we’ll find out a solution for you, one way or the other! :slight_smile:

Thanks again for working with us on this one.


#15

Hello,

Ok i will try few things and i let you know if that come back to work :slight_smile:


#16

Hi Support
I have a similar issue where I can’t reorder mockups or drag anything. I can only double click to add.
My Balsamiq version is Version: 3.4.1 & MAC OS 10.12.1

Sanj


#17

Sorry about that @sanj. This was a super nasty bug for folks who upgraded to 10.12.

The good news is that it should be fixed now. If you grab version 3.5.5, you should be able to drag and drop again.

Sorry again for the trouble, my friend. Let me know if you continue to see issues after the update.


#18

fixed thank you

Regards

Sanjeev Arora
CEO/Co-Founder
Tabillo http://www.tabillo.com
416-454-7648
sanjeev@tabillo.com


#19

I just upgraded to 3.5.5 and had a question related to reordering the mock-ups. Are you able to reorder the Alternate Mock-ups? Also, can you rename them?


#20

Hi @JoeReynoso,

Thanks for getting in touch about this.

While you cannot reorder alternate versions of a mockup manually, you can indeed rename them. Since they are sorted out alphabetically, you can change the order this way. More details on this page.

Hope this helps! Anything else, we’re here. :slight_smile: