Increasing RAM on myBalsamiq


#1

Hi guys, I’ve noticed that at times, a pop up appears asking you to approve an increase in RAM to make the processing speed on the browser much quicker - is there a way to increase that manually? Im huge on hiffi prototyping and it’s running extremely slow at the moment.


#2

Hi @billygeorge,

Thanks for reaching out to us.

Sorry to hear that you are experiencing some slowness using myBalsamiq.

Could you please share more details about this?
When do you experience it usually: inside of the editor or on the navigation maybe?
Is loading the editor taking more time than it used to?

We do not have such setting in myBalsamiq and I am not sure about which pop-up appeared on your screen.

Just to make sure, please have a look at the pop-up mentioned on this page: http://support.balsamiq.com/customer/portal/articles/517669
Is that the one you were referring to?

Increasing your RAM could indeed be helpful to improve your computer’s performances but this is not something that could be done via our little tool.

Hope this will be useful! Let us know if any doubt remains, we’re always happy to help however we can! :wink:


#3

Hi @Virgin

The speed of MyBalsamiq is fine when Im first starting out on a wireframe but once it starts getting more and more full of elements, it begins to start slowing down. Sometimes it gets to the point where moving an element using the arrow keystrokes takes up to 5 seconds per tap of the arrow - becomes frustrating. At times it even freezes and doesn’t respond but after waiting a minute, it tends to respond again. The navigation seems to be fine, its mostly inside the editor - loading the editor itself is ok, that usually takes the same amount of time - its moreover when using the editor its been a fair bit slower than usual.

In your link - yes that is the pop up that I was referring to - when it does appear I always allow it and it seems to help. Unfortunate their is no such setting to manually edit that because it seems that I may be hitting that limit of flash usage but it hasn’t appeared yet as I may not have hit the trigger for it to pop up.


#4

Hi @billygeorge,

Thanks for all the details provided here.

You can actually set this manually by following the instructions on the second half on this page: http://support.balsamiq.com/customer/portal/articles/517669
You will be able to set it to unlimited so no further pop up window should appear.

This should help but will probably not avoid any slowness to occur again. As you guessed right, adding more complexity (elements) to your mockup can result in this behavior. That is not something we can modify for now as running Flash player alongside brings some limitations.

On a side note, we have the huge project of going native and hope to have soon more news to share on that side! We are currently working hard on it and this will help in this case.

Thanks again for your report @billygeorge and please let us know if you need any further help. :smile: