[ISSUE] Unable to save project to original file location


#1

Hi,

For the past week or so I’ve been having difficulties saving my project to the file location on my hard drive. I have been saving to my Google Drive location on my laptop but recently on each save I get the following error:

_Failed to save the project: _
[IOERROREvent
type="ioError"
bubbles=false
eventPhase=2 text=“Error #3001” errorID=3001]

Furthermore, i get an further error stating that the file couldnt be saved to the original file location. The pop asks me to try a “Save Project As” or “Ignore”. When I try and save the project as something else I get the above message once again.

Anyone else having this issue and can provide some insight?

Thanks


#2

Hey @Gideon,

Sorry for the trouble here, my friend. It looks like the autosave mechanism is getting into a tug-of-war with Google’s sync mechanism. Google locks the folder that you’re saving so that it can sync the changes, and Mockups wants to save during that time and cannot.

The easiest way to solve this problem is to update mockups and disable autosave. That should prevent the errors.

While you will have to manually save the target file to preserve your changes, the backup file will still autosave as normal.

Let me know if that helps, Gideon!


#3

Hi @Brendan

Thanks for the tip. I’ve tried what you mentioned and will see how it goes. BTW I am using the latest version of Mockups

Version: 3.4.5 - 08/31/2016 08:28
Adobe Air Player Version: WIN 23,0,0,162

which is when the issue started. Previously to this I never had an issue as I worked from 2 different PCs (work and home) and used the Google Drive to always have the latest no matter where I was working.

If the problem persists I will let you know.

Thanks


#4

It’s a strange thing, Gideon.

Some folks have had zero trouble with it, and some folks have had nothing but trouble trying to sync.

Thanks for keeping us in the loop on this. We know it’s an annoying issue, and we want to make sure that turning off autosave solves it for good. :slight_smile:


#5

No unfortunately it didn’t.

I’ve now disabled the auto-sync on Drive as well to see if that fixes it.
So far each save has been OK.

Is there a maximum project size that I need to be aware of? Or maximum
number of mockups within a project?


#6

Nope, nothing like that.

That’s really strange that you’d still be seeing it. Is it only when you commit a save, or is it constant like before?


#7

It seems to have settled now that I turned off the drive sync and auto-save
features. I’m manually managing it while working on the mockups. The error
was happening on a commit.


#8

Ugh, I’m sorry about that, Gideon. I’m glad it’s solved for now, but what a pain.


#9

Brendan - I’m having the same issue Gideon reported here. New install of Balsamiq and Adobe Air, latest versions all around. Attempting to save locally to hard drive, not using Google Drive and no auto-save enabled. The only place Balsamiq lets me save files is to the root of my Windows 10 user directory - literally c:\Users[username], not even to a sub-folder like Documents.


#10

Hey @dufekmc,

Sorry for the trouble with saving your files. I’ve just replied to your email but wanted to let you know here too.

We’ll stand by for you email reply and we will go from there. We’ll do our best to help! :slight_smile:


#11

Hi all

I have exactly the same problem as dufekmc described. I am new customer, so new installation of the latest versions. Save is only possible under c: \ Users \ … Also not on the desktop. I have disabled AutoSave, no effect.
I would like to save the data on the Google Drive, because I partly work at home. I have no problem with other applications. Why not go with Balsamiq?

Thanks for help


#12

So sorry for the trouble with this, @JensG!

Just wondering: are you using an administrator account on your machine?

Could you please send us the error message that you are getting via support@balsamiq.com?

We’ll stand by for your email and we’ll do our best to help!


#13

sent…
And yes, I’m using an Administrator Account. Additional, I have Full Control on the Folder and I’m the Owner of the Folder.
If I run the application as administrator I get the same message.
If it helps: Windows 10 Pro, 64bit, Latest Updates


#14

Thanks @JensG! Just replied to your email.


#15

Thanks @Virgin
With your help I could solve that.
The cause is Bitdefender. In the Safe-File feature, there is a log entry that blocked access by Balsamiq Mockup 3.
I have added a safe file exception and can now save anywhere where I have access.
Your support is really amazingly fast and competent. Many Thanks!