Issues with changes not saving


#1

Hi there,

I’ve had multiple issues with my work not saving. I will mock up multiple pages and click save multiple times prior to exiting only to find on re-opening the file that the work isn’t there anymore.

I’ve been able to export all my mock ups to PNG first and they save fine. However exporting them to pdf tends to show up what is not going to be saved.

Any suggestions on how to fix this?


#2

Hi @Jan_au,

So sorry for the snag!

We introduced the auto-save feature with Balsamiq Mockups 3 so you shouldn’t have to manually save your project (https://docs.balsamiq.com/desktop/intro/#autosave).
Could you please check on the version you are running? If not the latest, please grab version 3.2.2 here: https://balsamiq.com/download

We just improved the way our tool behaves to avoid any data loss, you can find all details regarding our latest update here: http://blogs.balsamiq.com/product/2015/10/01/3-2/

I’m sorry for any data loss you might have experienced, that is the last thing we want for our users! If I can help rebuilding any lost work (possibly using your exported PNG files), please send me an email to support@balsamiq.com, I’ll be happy to help with this!

Let us know if you still hit any snag in the latest version, we’ll do our best to fix it straight away!


#3

Oddy enough, after upgrading to Balsamiq 3.2.2 ( My previous installed version was 3.1.9 ) today, I’ve encounter saving issue twice in a row, got error code like…

Loading Project Error (error 6026)

Still try to ping pong how to reproduce it. Currently both error happens in the same file (I’ve save it to another file when error occurred which suggest me to save in another place - after I saved and close all browser - I’ve working with online and offline Balsamiq at the same time - the original file even disappear from my local drive. Glad I save it to another one.

Will report back once I’ve encounter it again.


#4

Sorry to hear that @samho!

Let’s see what’s causing this on your side:
Are you working on a VPN maybe? Is your user profile stored on a central server?

Did you experience it only with an existing file that was created before the update?

Sorry again for the snag. If it persists, please feel free to send us some details to support@balsamiq.com if needed. This way we will dig deeper!


#5

Hi Virgin!

Nope, I did not use VPN at that point - the file is storing on my laptop’s harddrive.

I have issue with the file created long ago, with constantly modify it over those months. ( Fortunately the “save to file with other name” feature save it, alongside with my multiple copies around our local server ) Haven’t experience it with newly created file since updated to new version today - but it may due to the complexity of created file? The file I have trouble with consists more than 30 pages and numbers of alternative version for some of them.

If I have that happens once again, will try to collect as much related information - anything you like to know about?


#6

Hi Virgin,

Thanks for the reply - will try downloading new version to see if it fixes. I didn’t get any error messages to say that it hadn’t saved previously when I’d been using it. Not sure if it is also because of number of pages I have in my mock up - have about 40 different pages, would that cause it?

Unfortunately due to the nature of work I’m doing for a client I can’t send you PNGs to re-create as they are confidential but thanks for the offer.

Jan


#7

Hi Virgin,

I just tested making a small change and saving the new version, so far so good. Will let you know if I have any more troubles.

Thanks,

Jan


#8

Hi there,

Glad to hear that things seem to be back to normal in the latest version @Jan_au and @samho ! :smile:

The number of pages used shouldn’t be an issue here but the more complex a project is, the more it can be exposed to potential issues generally speaking.
Thank you both for sharing the details. If that ever happen again, any steps leading to the issue might be very helpful for us to try reproducing it here. Also, sharing the file (via support@balsamiq.com) remains the best way for us to help and we always keep your data in the strictest confidence and only long enough to try to debug your issue.

As I mentioned earlier, we are always actively working on reducing any potential cause of data loss as that is the last thing we want for our users! Our last update made a big step in that way but please let us know if you hit any snag.


#9

How do we recover lost changes?
I am using the latest version, and have lost an entire day’s worth of work due to this exact issue (explicitly saved before closing balsamiq).


#10

Hi @Lara_Pietersen,

I’m so sorry to hear about that! Loosing data is the worst thing for us to do so let’s try to get your data back.

As I mentioned above, we recently added a new backup system of all projects locally to an internal folder (starting with version 3.2.1). Here is the way to access the local store folder where these backups stay: https://support.balsamiq.com/desktop/backup/

Also, were you saving the file locally or on a network drive? We strongly recommend to keep a local copy of the file, especially while working on it to avoid any similar issues.

Sorry again for the hassle with this, Lara. Please let us know if you need any additional instructions to find a working version of your file, we’ll do everything we can to help!


#11

I’m having the same problem as Lara. What’s going on?

I downloaded the trial version of Balsamic Mockup two days ago with the intention of buying it, very excited to be able to present a client with wire frames instead of Word docs for a site we’re building.

To test it out I built the beginning pages of a project. Saved it and it’s gone, though a blank doc appeared in the folder labeled “New Project” with nothing inside it. Did the same again today. Gone.

I was jazzed at the idea of being to hand off the project to the client and developers in a more finished form but this is awful. I’ve wasted hours on this and I’ve got deadlines looming. There is no way I’d pay money for this if I couldn’t be sure the projects would save.

What can you suggest that will guarantee that projects won’t be lost?


#12

I had the same problem and worse of all, when I restarted the machine, the Balsamiq file was gone. The previous day’s work gone without any exported PNGs :frowning2:

  1. Installed the latest version
  2. I then went to “…\User\AppData\Roaming\Balsamiq…\Local Store\LocalProjects” (this is on a Windows Machine) and tried out all the temp files until I found my work. I opened it…
  3. and did a “SAVE AS”. Problem solved.

#13

Sorry for the hassle with this one @AJKock but I’m glad to hear that you were able to get your work back. I just replied to your PM, we’ll do our best to help!