Keyboard shortcuts for Zoom All to Fit and All to Actual Size (1:1) are missing


The keyboard shortcuts for Zoom All to Fit and All to Actual Size (1:1) are not working anymore. The function does, but only from the View menu (which is very cumbersome). Interesting detail: The menu still shows the keyboard shortcuts, while the web page does not.
Please bring the shortcuts back, I used to use these very often.


Hi @PhilippQF and sorry for the trouble with that one.

I’ve just tried to reproduce this and while it seems to work fine on Mac, the shortcut for Zoom All to Fit (SHIFT+CTRL+0) does not seem to work on my Windows 10 VM but the shortcut for Zoom All to Actual Size (SHIFT+CTRL+1) seems to work.

Is that what you’re seeing too?

Also, can you share your configuration (mostly the OS used)?



Sorry, I forgot to include the information on my system. I’m running Windows 10 Enterprise 64 Bit. Both shortcuts do not work at all.


Oh wait, you’re right. Now Zoom All to Actual Size seems to work. But Zoom All to Fit does not.


But then again, if I call up Zoom All to Fit from the menu, balsamiq seems to hang, and it’s using a lot of memory.

This happened twice today.


Thanks for confirming @PhilippQF!

I’m passing it on to the dev team so they can work on fixing this one.


I just found this: Is that maybe connected?


Thanks for the heads-up but it might be a different bug since Windows 7 seems affected too. We’ll keep you in the loop.


Hi @PhilippQF,

Sorry for missing it earlier but it seems like these steps may help you to solve this one on your machine. Could you give it a try and let me know if that helps?

Thanks! :slight_smile:


Hey @Virgin, that did the trick!
It is quite confusing to have this default setting “left alt+shift”, as the Windows 10 standard for switching input language and keyboard layout is “win+space” (which luckily still works).
Thanks a lot!


On Windows 10 using Ctrl+Shift+0 – I have found using the zero on the 10-key keypad does not work, but using the zero at the top of the keyboard does work.


@russ I can confirm that!


@Virgin An update on this: I just had my Windows 7 system changed to Windows 10, and the problem came up again. So I looked into the “Switch keyboard layout” setting as described in the link you gave, and I found it was already set to “Not assigned”. Nevertheless I confirmed the dialog with “OK”, and that now did the trick. So it seems the internal Windows settings may not be what Windows shows in the dialog …


Weird one @PhilippQF, thanks for the update! We’ll keep an eye on this one for our next major version, hopefully this article should help there too.


Recently <ctrl + shift + 0> does not work on Windows 7 nor 10 anymore, despite the correct settings in Text Services and Input Languages. <ctrl + shift + 1> works, but only with the “1” on the main keyboard, not in the numeric section.
I really like to have that fixed because I have to switch from 1:1 and fit to screen a couple of dozen times every day …


So there is something weird here, and we will have to dig deeper…

It stopped working on my install of 3.5.14, so I started going through older versions (where it worked). Got to 3.5.13 and found it worked there, so I assumed it was a recent regression.

However, when I reinstalled 3.5.14, I found that it worked in that version as well…

Something funky is going on. Just for fun, try reinstalling 3.5.14 and see if that fixes it. Let me know, and we will go from there.


Yeah, this is really strange. I did a reboot in the meantime, and all of a sudden both shortcuts worked. Now after working for an hour or so (and having closed and opened balsamiq several times) we’re back to <ctrl + shift + 1> being OK, but <ctrl + shift + 0> not working.

Re-install did not change it for me.

Maybe it’s connected to some company policies that mess up the Windows settings at unexpected intervals? No idea :frowning:

Suggestion for a workaround: Can you find a pair of shortcuts that works reliably on all platforms?


That’s a really strange one indeed! I’ll get back to the dev team in the morning (EU) about this one and see how we can improve this. Sorry for the hassle @PhilippQF!