Links in datagrid in Mockups 3


#1

all,

I used to be able to link the items in the datagrids in Mockups 2 by adding the name of the mockup bmml file in parenthesis next to the datagrid item like:

{item](item details mockup.bmml)

However it doesn’t work anymore in Mockups 3. I was not able to find it in the docs. Any suggestion will be appreciated.

Thanks,

-s


#2

Hi there @sparievs.

I know you and I are figuring this out over email, but I wanted to post the solution here in case other’s run into this issue.

Mockups 3 works with links a little differently than Mockups 2 did, mostly because everything is contained in the project (.bmpr) file. You no longer need to specify a file name for the linked mockup, just the mockup name would do.

For Sparievs’ example, it would be [item](item details mockup)


#3

thanks for the reply.

and i change the link already,and, unfortunately, it still did not work.

btw, it would be nice if the bmml file extensions could be automatically removed during the bmml import step. Just my $0.02.

thanks,

-s


#4

Brendan,

I’m running Balsamiq Mockups 3.1.9 and I have also tried to create a link inside a datagrid. At first I tried linking to another mockup in the same project but that did not work. Then I tried just going to www.google.com and that didn’t do anything either. Here is my markup:

Role,Firm,Contact,
Architect of Record,,,[Assign](www.google.com)

Finally I got it to work by adding a space between the comma and [Assign].

, [Assign](www.google.com)

However, I’ve not seen where this is documented that I need to use a space. Is this a bug?


#5

Yeah, that’s exactly the issue sparievs and I had. It’s definitely a bug, no question there, but we aren’t sure if it is fixable yet. If it turns out that it’s a side effect of the control’s code, we will make sure to document it.

I’m sorry for not updating this thread with the solution, @skeletank. Thanks for posting it up here for others who may run into this! :smiley: