Memory usage growing since version 3.0


#1

Since my switch to Mockups 3.0 my mockups instance keep using more and more memory over time.

I’m using
Version: 3.0.5 - 03/26/2015 10:18
Flash Player Version: MAC 11,9,900,169

I’m not sure whether this memory leak is because of the specific project, or if it’s a general bug.
The project has been imported from an older version 2 project folder.

The actual project file just takes up 2.8 MB of diskspace. When opened Mockups starts off with a memory usage of 180 MB’s, which of course is acceptable. But after a while of fiddling around with it, nothing fancy, simple notes and adjustments, it grows to enormous sizes. Now it’s at 700 MB’s. Still doable, but I might restart it in a bit…

Is there anything I can do to fix this?


#2

I have experienced the same issue.
I can reproduce it by simply switching between the mockups of a project.
In a 15 mockup-project I have ~25MB additional memory usage after every loop…

B 3.0.5 on Windows 7 x64


#3

I’ve experience the same thing.


#4

Guys,

I imported a folder containing legacy (pre-Balsamiq 3) .bmml files - 32 of them - and it grinded to a halt after I started fiddling with the symbols (also quite a collection) and clicking between mockups.

It has crashed once and is VERY slow the rest of the time.

All this was within a few hours of starting use of Balsamiq 3 today. I can run Balsamiq 2.2.19 at the same time as V3 and it performs quite well. No lagging/hanging.

Any ideas as to how this can be solved would be appreciated.

Please help!


#5

Hi all, sorry for the trouble. This is something that is on our list, and we are working on improving it. We’ll also look for workarounds to help you get unstuck. :frowning: Sorry I don’t have better news!


#6

Thanks, Ben.

Sticking to Balsamiq 2 'till 3’s memory leak is fixed is not a bad thing - for me at least.

Still the best ‘mockupping’ software out there.


#7

Hi Ben,

Thanx for the update. I’m sticking to Mockups 3. I love all the improvements!

It’s a weird thing. Today the project is still gradually growing in memory size (it’s at 500 MB’s atm), but I havn’t had to reboot the application yet.

Best regards,


#8

Perhaps the bloat-type behavior is restricted to when one imports legacy files?


#9

Hi everybody!

We fixed a memory leak.
Can you please try the version 3.0.8 if you still have a significant memory increase over time?

Please note when you access a mockup you have not accessed in a session so far the app will store some information in the cache. We do this so the loading time of a mockup is faster when you access it a second time.

Here are the release notes:
http://blogs.balsamiq.com/product/2015/04/09/more-little-improvements/


#10

I am using version 3.1.1 that is dated from 4/28/2015. I am having issues with the application lagging, freezing, and crashing. I’ve lost work multiple times, even though the program says it is auto-saving. I also save after almost all changes and still seem to lose work.

Is there a maximum number of mockup pages a project can have? I didn’t seem to find any problems until I hit the 60-70 mockup page range. I now have 105 pages and the application crashes on me every few minutes.

Please help, thanks.


#11

Hey @ptrate, let’s get you on the latest version and see if that doesn’t fix your crashing

https://balsamiq.com/download/

Please let me know if you are still having issues after you update :smile:


#12

I actually just downloaded the latest version, 3.1.6. It has been running okay but just crashed on me. Can I run two instances of Balsamiq at the same time without causing too much CPU usage? Another thing that could be a problem is that when I paste wireframes from one project to another, it seems to be creating duplicates of “symbols” and is causing a huge pileup of “copy of copy of copy…” symbols that I imported. What do you think?


#13

Hi @ptrate,

Sorry to hear you are still having issues. Let’s dig a bit more on those.

Could you please elaborate on the “crash” aspect? Does the app quit unexpectedly, or hangs, or starts behaving weirdly?
Regarding the issue with duplicates, does it occur with every copy/paste of your wireframes from one project to another ? Do you have any example to share (maybe via support@balsamiq.com) so we can have a look at it?


#14

Ohh noooo. I ran into the memory leak bug again.

Yesterday I updated to 3.1.7. Today, after a full days work though, balsamiq was using 1.5 Gigs of memory. When I closed my two projects, it was still using the same amount of memory. That HAS to be a leak right?

Closing the application and reopening the project fixes the problem (for now).


#15

Hey Wytze,

The dev team is really close to finding and closing this leak. I don’t have an definite time table, but stay tuned to http://blogs.balsamiq.com/product/

It’s coming, I promise! :smile:


#16

Thanx for the feedback.

Balsamiq also seems to use an overly high amount of CPU power since the update. Off and on though, sometimes resulting in erratic behaviour when dragging around objects. Is this part of the same bug?

Hope it is and that you guys fix it soon.


#17

Darn guys,

I’m at 3.1.9 as of tody and balsamiq seems to grow in memory at little faster again. I just restarted Balsamiq and already it’s at 600 MB’s. Though now (I’m not active ly working on but writing this) is seems to stay at a constant amount.

I have to say, with all releases between March 30th and today none really fixed the memory leak. At the end of a working day I’ve always restarted Balsamiq once or twice (I do this when it reaches around 1 Gig of memory)

Do you need my project file to test it? If so, let me know.

Best regards,


#18

A heads-up around the memory leak issue.

As I understood from my session with @Virgin you guys had the leak pin pointed as an AIR related and difficult to solve problem. But now I’m working with Balsamiq for Drive and am experiencing the same problem. I’m working with firefox (because of the drag-copy bug in chrome) and the shockwave plugin content process (flash) grows over time to amounts of over 1 GIg.

Again a restart fixes this temporarily.

This is bad and good news I guess. On the one hand the issue is not just issue related to Mockups for Desktop, but on the other hand the issue might be solvable because it’s not the supposed unsolvable AIR-related memory problem.

BR


#19

Hi @WeeDz,

Sorry again for the trouble with this one.

Facing the same kind of issue in both versions is due to our Google Drive plugin version using Flash player to run (comparable to Adobe AIR in Mockups 3 for desktop).
We are trying to reduce the pain but the big step to help with this will be going to native as I mentioned during our last session. We hope to have more news to share soon!

Thanks for reporting this @WeeDz, as always, and for continuously helping us tracking down bugs in general! :wink:


#20

I’m guessing this issue is still not completely solved.

I suspected AIR dependency might be an issue before I found this thread.

I’m on Balsamiq 3.2.4 and AIR 19,0,0,169

Whilst all is well working on a project of say 20 pages, as soon as I get to 30+ and a big pile up in Symbols, the application crashes regulary, even though there is plenty of available system memory.

The crashes seem to happen most often when viewing Symbols.

At this point Balsamiq 3 seems fine for a small concept, but if you want to work on anything more complex it’s back V2.

I’ve already reported to support, but just wanted to see what others were experiencing.