Mockups not working on MacOS Mojave


#1

I updated to the last version of macOS 10.14 doing a clean install, formatting the disk and reinstalling everything, but Balsamiq is no more working :confused: I tried to install several times but I always get a white or black screen like in the screenshot. What is the problem?

Screenshot


#2

Hi @Dhug95,

Thanks for the email and apologies for the issue here - we have members of the team using Mojave here so this isn’t a general issue with the desktop app.

Can you confirm you’re using the latest version of the app: https://balsamiq.com/download/

If so, can you try updating Adobe Air (https://get.adobe.com/air/) and get back to me if the issue persists?


#3

Thank you for the quick reply.
Actually I’m not able to install Adobe Air as well, I get the same result:

Screenshot

(The screen is black but it appears white in the screenshot)

Btw yes, I checked multiple times and I’m using the latest version of the app


#4

Thanks @Dhug95.

It’s a little worrying that you’re not able to install Air from Adobe… It seems like something - an anti-virus program, security or such - is blocking the app. Can you think of any software on your machine that might be preventing these apps from running?

Let’s take a step back. Can you download the penultimate release of Mockups and let me know if you’re able to install it or the same issue occurs: https://build_archives.s3.amazonaws.com/mockups-desktop/Balsamiq_Mockups_3.5.15.dmg


#5

I found a solution!
This morning, before trying to do what you told me, I tried to download and install Air from Firefox, which I never use, apparently with no reason… and I had the same problem! Black screen, app not working. Till now I had this problem only with Balsamiq, that’s why I thought it was a problem related to it. Now I tried to look on Bugzilla and I found this problem: the solution is to use the commands

defaults delete -g NSRequiresAquaSystemAppearance
killall Dock Finder

This is because I changed the value of that Boolean variable in the system in order to have only the top bar of the Finder dark, and everything else light. It’s possible to revert it and change the value to false, but the solution is to completely delete it. I wrote all details so this can be helpful for other people.


#6

Thanks a lot for keeping us in the loop and sharing the solution, @Dhug95.

Those steps could definitely be useful for other users!

We’ll be here if you need anything else. :slight_smile: