Balsamiq Community Discussion

Old mockups keep on showing up

Dear community, i am facing the following issue:

  • created initial version of the mockup. After a couple of hours have updated it with the new components and saved to the project. When selecting an updated version in the ‘Edit Balsamiq Wireframes’ window, i can see the latest mockup version.
    However, after selecting latest version and clicking ‘Save’, my confluence project is updated with the old version of this mockup…

I have tried refreshing pages, closing and opening…reloading…no luck seeing the latest mockup version.

Can anyone please help?

Thank you in advance.

Hey @andriyk, it sounds like the PNG file that is attached to the page isn’t updating - I’m sorry about that!

Would you mind opening the project again and, once in the editor, going to Project > Export > Export To PNG? It will ask you if you want to download the PNGs or attach them to the page, Choose Attach.

Let us know if that fixes the issue. :slight_smile:

Thank you for getting back so quickly :slight_smile:
When i try ‘Attach’ i am getting the following
"Oops, export failed to attach file to the content {“authorized”:false,“valid”:true,"errors,“successful”:false},“message”:“Cannot add a new attachment with same file name as an existing attachment:balsamiq_wireframe_…-…-…-…-…_Master.png”

Ahh, sounds like a permission issue, which is weird but not unheard of.

Can you find the duplicated png in the page’s attachments? If so, delete it and try the process again.

i have just created another, ‘new’, wireframe and copy pasted all the content. Now it works fine. I guess the versioning has been corrupted on the older wireframe

Ugh, sorry about that, @andriyk.

Let us know if you see that again, and we will dig into it more deeply.