Balsamiq Community Discussion

Paste image from Windows 10 Snip & Sketch tool doesn't work

The latest Windows 10 update includes a new screenshot tool called Snip & Sketch. If you take a screenshot and then try to paste it into Balsamiq, it doesn’t paste. You can paste into other apps (gmail for example). However, the old Snipping Tool still works.

Hi @Jon_Asbury,

Thanks for the report. I’m not sure what they’ve changed here but we’ll take a look.

In the meantime, you should be able to save the snipped image as a PNG (File -> Save as…) and import it into your Balsamiq project as an image asset (see: Working with Images and Assets). Does that workaround get you by for now?

Thanks Alasdair. The old snipping tool works so I’ll just use that for now.

Have a great day


1 Like

BTW I also filed a bug report with Microsoft against their new Snip and Sketch tool.

1 Like

I saved it but it doesn’t save the edit - only the original image.

Hi @barbiejh,

Thanks for the post and welcome to the Balsamiq forums!

I’m a little unsure what you mean and don’t want to assume - can you elaborate a little on exactly what you’re doing and where the process is breaking down? If it’s helpful to attach a screenshot or two, go ahead and do that.

If you think it would be easier to work through this in a call, drop an email to and we’ll set it up.

same here! i use the old snipping tool all the time, without saving a snip, you could paste the selected area straight over to live mail, it was great, even if you selct the ‘copy’ icon in the top right of snip and sketch, it doesn’t paste across.
Hey Jon, where did u go to log a bug report?



nvm i found it

1 Like

I’ve tried the methods above and the only option that works is using the old version “Snipping Tool”. “Snip & Sketch” does not work when using a saved PNG image or a JPEG and then importing as an asset. Snipping Tool will be removed sometime in the future leaving us only with Snip & Sketch. When this occurs I’ll be forced to use Visio because I primarily use the snipping function to make clean mockups in Balsamiq. Please look into this because I use Balsamiq daily and do not want to have to use Visio because I love Balsamiq. Thank you.

Hi @awinning,

Thank for the email and sorry for the frustration here. I just ran through this quickly using version 1.1903.2331.0 of ‘Snip & Sketch’ on Windows 10 and if I “Save as…” my snip I am able to import the resulting PNG into Mockups 3 as an asset.

Would you mind running through the steps you’re using so I’m not missing anything because you should definitely be able to import a PNG saved from ‘Snip & Sketch’ into Mockups 3.

One other thing - would you make sure you’re using the latest version (3.5.17) of Mockups 3 for Desktop:

Finally, you may or may not know that we’re in the process of a major update to our desktop app. - Balsamiq Wireframes for Desktop. We’ve been working on it for some time and it’s getting close. In short, the new desktop app will be native on both macOS and Windows and drops our dependency on Adobe Flash/Air.

I just tested pasting an image from ‘Snip & Sketch’ directly onto the canvas in Balsamiq Wireframes for Desktop and it works fine. If you’d like to join the beta test program to get an early look at the new app, drop me a DM and I’ll get you set up.

I’m one of the people having trouble with Snip & Sketch on the desktop application. I’m using Version: 3.5.17. Steps to reproduce:

  1. Open Balsamiq desktop to a new blank page
  2. Go to Snip & Sketch and initiate a snip
  3. Use the copy icon in the Snip & Sketch app
  4. Go to Balsamiq and select the paste option or Control V
  5. No image is displayed on the blank screen

Alternate process that also does not work

  1. Open Balsamiq to a completely blank screen
  2. Go to Snip & Sketch and initiate a snip
  3. Use the save icon in the Snip & Sketch app and save a PNG or JPG
  4. Go to Balsamiq desktop and select the import option and select to add assets
  5. Select the png or jpg and import
  6. Balsamiq looks like an import is in progress but no image appears on the blank screen

There’s an additional step you need to try - can you give this a go and let me know if it’s working?

When you choose Project > Import > Assets… the image is added to your assets but it’s not added to the canvas. Can you click the “Assets” filter in the UI Library and see if your image is there after importing it?

Double-clicking should add it to the canvas

Alasdair, I did try the import Assets process and t looks like an import is happening but nothing even appears on the screen. Hope this helps.


I did see that they are in the Assets folder. This is a good work around but please fix the other paste issue!


1 Like

I forgot to email you back and realized I was not looking under the Assets folder, all is well and is working just fine! Thanks Alasdair for your exceptional



1 Like

Has this ever been resolved. Copy area works once but then after that it gives up and stays with the first snip and that is my forever snip until i clear the clipboard. So I am suspecting the program does not have a “if clipboard is full, clear clipboard” so i found another way to work around this by using Settings>System>Search for settings “Clipboard Settings” (without quotes) and turn on the Clipboard history and then if i copy something and want to paste i use winkey-v instead of ctrl-v. and I can clear it there any time I want or just pick until it gets full then clip again. BUT… I discovered that even when its clear it is not the problem so has to be something else in the program. Some bug for sure.

Hi @Samuel_Murrah and thanks for checking on this one.

We haven’t solved the issue in Mockups 3 for Desktop (our older Desktop version) but you should be able to save the snipped image as a PNG ( File -> Save as… ) and import it into your Balsamiq project as an image asset (see: Working with Images and Assets ) instead, as Alasdair mentioned.

That being said, our newer Desktop product (Balsamiq Wireframes for Desktop) is not affected by this issue so feel free to give it a try and please let us know if you need more time to try it out and see it fits your needs. :slight_smile: