Balsamiq Community Discussion

PDF Export Quality


#41

Hi @Brendan and thanks for the quick answer! I am using Balsamiq on a macOS and I am sure they used to work back when I created the PDF but somehow the links must have “depreciated” over time, at least thats how it feels, since I am still using the same macbook that I used back then. But let me get this right, even if this problem would exist in my current version, it isn’t a problem at all since I am exporting my final PDF using the Cloud application anyways, correct? So the only things left to do for me in order to be safe is:

  1. finishing my mockup (including all links) and saving it as a regular .bmpr
  2. uploading it to the cloud in order to export the PDF in highest resolution and with no mixed up/missing links
  3. ensure that my clients are using Adobe Acrobat when viewing it (not just the native windows viewer or mac´s preview)

#42

We aren’t 100% sure what is going on with the links, to be honest, @shackleton. The only other case where we have seen this was on an old version of MacOS (ElCapitan) and Preview was somehow overwriting the links. We don’t know how because we didn’t have physical access to the machine, but that was the only time we had heard about it.

But yes, your process should be fine. The links should work as soon as you export them. As far as we know, they aren’t mangled unless you open them in Preview (assuming your case is the same as the one we investigated).

They can use any modern PDF viewer (even Preview).


#43

alright @Brendan thank you very much for your help! I used mac`s built-in preview if that helps, maybe this indeed was the reason. Thank you for your great support, it is highly appreciated!


#44

Hi @Brendan and @Virgin I am sorry but I just exported my PDF using the Cloud which all worked fine and the quality is much much better as well, my only problem that I have and thats a major problem on my end, that the links won’t function properly. I linked the first pages of my mockup to try out if it works and neither do they all work properly on my mac using preview and adobe acrobat afterwards, nor do they work on a friends windows lap top when using adobe acrobat. Some work, some dont, its very random and sometimes (especially on my mac) its like as soon as I clicked a button/link that worked and close the document afterwards, the same button/link wouldn’t work again after I reopen it. I really dont know what to do now, I am pretty much out of options and only have a week left to hand in the working PDF, would be great if you have any solutions in mind, let me know if you need any details/want to check out my PDF, etc. Best, Shackleton


#45

Hmm, it could be that the links are layered @shackleton.

Why don’t you shoot us an email and we can dig into your account and see what’s up.


#46

Hi,

Is there any update from Balsamiq with regards to vector PDFs from the desktop application (opposed to cloud)?

Thanks,
Dominic


#47

Hey @Dominic. We are actually getting pretty close to a new desktop version, so I would keep your eyes peeled for it in the first half of next year. I wrote a little bit about it in our dev update blog post.

If you like, I can add you to the beta list. The desktop beta only works with Balsamiq Cloud at the moment, but it will work locally by the time it’s released.

Let me know if you’d like that, and what OS you are on, and I will get you added!