Rectangle colour changes (bug)


#1

The following basic procedure is repeated:

Duplicate a previous mockup of a webpage (based on a symbol) and make content changes (i.e. design User Management screen)
Duplicate that mockup, draw a borderless rectangle over the entire page, set to black, 50% transparent, then draw a new rectangle on top of that which forms the foundation of a popup/modal screen (i.e. an edit screen).

Some time later, duplicate that screen in order design a different popup window (i.e. a deletion prompt).

The black 50% rectangle has suddenly changed to white!

If I go back to the previous mockup, I notice that the rectangle appears black as expected but the Background is actually set to white.

This has happened a number of times when duplicating mockups in this project.


#2

Hi @Ryan,

What a weird bug! I’ve tried to reproduce it here but it seems to behave as expected and keeps the background color. Could you please check that you are running the latest version (3.4.2)?

Also, could you check if this happens also on a new project, or only with a specific one?

If the issue persists on your end, could you please share a screencast of the issue via support@balsamiq.com? We’ll do our best to help with this.


#3

Hi @Ryan,
This doesn’t address the color change issue, but wanted to point out there is a Modal Screen object you could use instead of the black 50% rectangle. The nice thing about the modal screen is the color and transparency are a fixed value for this object. I too had been using a black rectangle until I recently discovered the modal screen object.


#4

Yes I’ve been on 3.4.2 since its release. I’ve not been able to reproduce today - at all since I discovered the black box with white colour picker (and then changing that to black). Just raising it and seeing if anyone else has had similar occur.

Thanks for the modal control tip @russ


#5

So I had just dropped a new rectangle on another page and set it to black, then 50%, and nothing went wrong, so I write up the above post. As soon as I click submit, I switch focus back to Balsamiq, and click the rectangle to see it’s background colour change! Recorded a GIF below:

I’ve cropped off some project details, but the actions are as follows

  1. Click on black rectangle. Observe background color has changed itself back to White.
  2. Duplicate the mockup. The new mockup shows a white rectangle.
  3. Switch back’n’forth between the first and copied mockup.

#6

Ok so I’ve just tried to follow your steps by putting the focus on another app and back to Mockups but it still doesn’t show up for me. :confused:

Can you confirm that this happens if you try to reproduce it in a newly created project?
Or is it only this one?

Thanks so much for sharing all the details, @Ryan! Let’s hope we can replicate this so we can get it fixed ASAP!


#7

It’s not impossible to replicate but it’s also not easy either. Very intermittent, a fluke to catch it.

I had it once after moving a mockup to a new project file but not again since.