Rendering bug on an external screen

Hi balsamiq dev team,

after the balsamiq cloud access is now gone from the desktop app, our team was forced to move to the web version.

Besides that everytime when opening a project we now have to annoyingly keep the loading tab and window active, otherwise the project will never load (because throttling the background processes is a standard browser behaviour), we now also receive the following rendering bugs:
The video was blurred due to legal reasons, in case you would like access to the unblurred version to analyse the behaviour, feel free to contact us directly.

The bug occurs when a group of elements is double-clicked and the screen view changes (zooming, panning but also on simple mouse movement).

System: MacBook Pro 15-Inch 2019
macOS: latest Ventura 13.2.1
Browser: latest Chrome Version 111.0.5563.64 (Official Build) (x86_64)
Screen: LG UltraFine 5120 x 2880 (recommended and sold by Apple)

We have more than 130 projects in your cloud and use your software every day, but we did not experience this problem previously in the desktop app.


The rendering errors occur, fortunately less often, but also when using balsamiq on the laptop screen (smaller resolution 2880 x 1800)

Oof, that’s brutal, @matejrajtar.

I can honestly say I have never seen that - and have multiple folks who are running into this?

Let’s try a couple of things, just to rule out the easy things.

Can you log into Balsamiq Cloud in an Incognito Window? If the problem persists there, can you try using Safari?

I have a 2021 MBP with that exact monitor, and I’ve never seen that happen. Is the LG a true second screen? Or is the laptop in clamshell mode, with the monitor being the primary (and only) display?

I’m sorry again for the trouble here. We will do everything we can to get it sorted.

Hi @Brendan!

Thanks for the quick reply. Chrome only, Safari shows no problems (apart from an extreme laggy zoom, during which the canvas elements sometimes disappear, which we got already used to also on the desktop version).

The incognito mode in Chrome unfortunately does not help, the symptoms including the green areas flickering back and forth are still there.

The MacBooks are used both modes in our team, clamshell and also true second screen, the videos were recorded while always both screens running.


Thanks for the update, Matej.

Unfortunately, this looks like a bug that Apple and Google have been fighting over since 2015. It has to do with the AMD chip in those Macbooks.

Let’s try this:

  • Visit chrome://settings/system in the browser
  • Disable Use hardware acceleration when available.

That’s the easiest fix. If that doesn’t work, we will try the next thing. :slight_smile:

This indeed solved the issue for us, thanks @Brendan! With the acceleration off we noticed a further drop in performance in terms of how responsive (or unresponsive?) the interface is, especially with many elements on the canvas. However, there are no visual bugs appearing anymore.

Do you also experience a delay in terms of seconds when doing any action, e.g. moving an element on the canvas using keyboard arrows or virtually anything else? This has been the case for us already on the desktop version, but now in browser with the hardware acceleration off it has gotten worse.

Is the balsamiq team working on improving the performance to level with the tools such as Miro, Overflow or Whimsical? Can we expect an update for this in the future? :slightly_smiling_face:

Thanks a lot,

We are constantly working on improving performance, @matejrajtar (in fact, this month’s release had a performance tweak in it). Of course, there is always more work to be done. We think some changes we are making over the next few months to trim things down will help.

The fewer things the app has the draw, the better. :slight_smile:

I’m curious as to how the app runs in Firefox and/or a Chrome incognito window. There have been situations where certain extensions have caused the app to run slowly.

@Brendan Thanks for the tip, will try to work in the incognito window without the extensions as well.

I believe in our case it is the amount of elements we need in our wireframes (labels, icons, etc.) although that should definitely not be the reason with the current technologies and computing power available.

Looking forward to the updates in the coming months.

1 Like

Hey guys, I am still having the same problem of Zooming in randomly by the app. I have already tried it on Safari and already disabled the hardware acceleration on Chrome.

What should I do? It is making my work very unproductive.

That’s strange, @Ahmet_Efeoglu - I think zooming may be a different problem, however.

It may be a keyboard or mouse issue if it’s happening in Safari and Chrome. Would it be possible to capture a video of the issue so that we can better understand what’s going on?

Sure so here is a loom video I recorded for it. This is making it impossible to work with the tool: Loom | Free Screen & Video Recording Software | Loom

I am not using a mouse and when it auto pans I am not touching any keyboard, it does it on its own.

Ugh, that’s wild @Ahmet_Efeoglu. I cannot imagine how annoying it is.

Let me sick @Florian_Brauer1 on it in the morning.

Is this just on the 2nd monitor? Or does it happen on your main display too? (If you’re using a laptop, does it also happen on that display?)

Lastly, does this happen when the window doesn’t have focus?

I am just using my Mac work laptop. It happens on my Chrome, Incognito, Safari. Has been happening 2 weeks.

No, it doesn’t happen when the window doesn’t have focus. It happens when I zoom to change something then it zooms and also pans.

Are you using a magic mouse or the trackpad on your laptop, @Ahmet_Efeoglu? Are you pinching to zoom in the situations where you are controlling the zoom?

Hey Brendan, I am not using mouse. I am using trackpad. I am on Macbook and for zooming Brendan, I am pinching.

I know you have done in it both Chrome and Safar, Ahmet, but would you mind trying in a private browser window (in the browser of your choice) just to cross that off the list?

Hey Brendan, I had also tried it in Incognito Mode for Chrome. Here are a few troubleshooting I did. In my own personal M1 Pro 2021, with OS Monterey, 14 inch laptop Balsamiq works great. No bugs.

In my professional M1 Pro, 2021, 16 inch laptop with Mac Monterey, it has the problem of auto zooming and panning. I assumed the problem might be screen size but when I resized the browser smaller and tried to work like that on my big work laptop, the problem persisted.

Hmm. That is doubly odd.

Does your work laptop have any 3rd party management software on it?

I was going to suggest updating to Ventura, but since your 14-inch M1 pro is on Monterey and not experiencing the bug, I’m wondering if there is a piece of 3rd party software that is gumming up the works.

Had the same ‘green panels issue’ and turning ‘hardware acceleration’ solved it, but now it’s supper laggy. :frowning:

Really appreciate a quick fix for this.

1 Like