Runnin Mockups 3 in wine - selecting with alt pressed doesn't work anymore


#1

Is anyone else encountering this problem?
I used to use this feature a lot, but apparently now that I have to run M3 on wine, the option of pressing alt and selecting elements e.g. from inside a browser controller (which is what I have quite a lot) is not working anymore. I don’t mean clicking individual controllers but by selecting an area, thus selecting all the elements inside that area.

If anyone understood my problem, great. Even better if anyone would happen to know a workaround for this - can I configure wine in some way, can I configure Mockups?


#2

HI @Inna_Kajaste!

I think I know what your problem is, but at the moment Wine is giving me a few issues, so I can’t fully test that it’s working.

If you answer yes to the following two questions, I’m pretty sure this will fix it!

  1. Are you using Ubuntu 14+?
  2. When you press Alt+Click it drags the whole application window?

You will need to set the mouse_button_modifier to a different key, by default it’s set to “Alt” which lets the system have control of the action for “Alt” instead of the program.

If you run the following command in Terminal it will set that button to “Super” (Windows Key) instead of “Alt”:

dconf write /org/gnome/desktop/wm/preferences/mouse-button-modifier  '"<SUPER>"'

Could be totally off here, but I know I had a similar issue with a different application that needed the “Alt” key. Hope it works for you! :smiley:


#3

Yes Keith, thanks, this is exactly the problem. I was able to change the key but as far as I can tell, it didn’t change anything. I might have to google some more with my specific distro to see what’s wrong.
BUT: Looking at this sheet http://media.balsamiq.com/files/balsamiq-keyboard-shortcuts-v3.png I’m not even sure if the function I’m looking for even exists in Mockups 3 anymore
. :confused:


#4

That’s still in v3: holding ALT before dragging makes Mockups ignore the shapes behind the mouse.

Sorry but I don’t know how to help you with wine/linux.


#5

@Inna_Kajaste

I have wine running now, think I may have found a weird workaround! For reference, I am using Wine 1.6.2 on Ubuntu 14.04.

First, make sure you don’t have ALT set as the “key to show hud” in your keyboard shortcut options under system settings. See screenshot below.

Now, within Mockups 3, try holding ALT+Z (Z can be any letter) and dragging to select items. :+1:

It seems like Wine waits for a full keyboard command before it sends ALT to the application. Hope this helps!