Save As does not always work when you close and start a new project


#1

I am using ver 3.3.12. If I have a project already open, and start a new project, I do not seem able to save the project using Save As. The only way I can get it back to working again, is to close the project completely and kill the process (it seems to be hanging on to the process even when i shut the project window down). When i open it back up, my new project is there and saved as the default project name i think, I can then save the project with the correct name.
I think when starting a new project with one already in use, it seems to open a new session and then perhaps gets confused :slight_smile:

I have seen some issues that appear related to this, however they are from 2015.


#2

Hmmm, @clarewilliams, it sounds like you’re hitting a runtime exception. That’s why it’s forcing you to kill the process to continue. We just need to figure out what’s causing it.

First things first, let’s get you on the most up-to-date version of Mockups. It is 3.3.14 as of this post.

Is it only happening when you have a specific project opened? If so, would it be possible to share your BMPR with us? We wouldn’t share it with anyone outside the team and would only keep it long enough to diagnose the issue.

If it’s happening with more than one project, can you give me a little more information about your setup so we can test it?

Namely:

  • What OS are you running?
  • How many projects are you working on simultaneously most of the time?
  • Do you notice any other weirdness in the app, or is it just Save As?
  • Have you noticed any actions that will reliably trigger the issue?

Thanks for reporting this! We will do everything we can to get it fixed :slight_smile:

Edit: Forgot to mention that if you can share your BMPR, email it to support@balsamiq.com and we will have a look!


#3

Thanks for quick response!!

Steps to repro (not consistent though i think!) I have upgraded to 3.3.14 and still experienced the problem.

Open an existing project
Close project via menu option (not the window)
Import BMML Mockups
Import Symbol library (to fix missing links)
Save As … and you don’t get the save as window.
I have only experienced the problem when i have moved from one project and started a new one. So this is saving a new project.

OS Win 7 SP 1
normally 1 maybe 2 project at a time, but we are in process of migrating version 2 mocks to version 3 and so are generally, importing BMML’s, importing Symbol library, carrying out any necessary modifictions, saving, closing project, and then repeating the above steps to convert our existing BMML’s into projects (Projects are generally consisting of several ver 2 BMML files)


#4

So strange, @clarewilliams.

Would you mind shooting an email to support@balsamiq.com? I’d like to get a little more information from you so that I can have Florian dig into it. That will probably be easier over email if that’s ok with you. :slight_smile:

Sorry again for the trouble here.