Save doesn't Work. Save As doesn't work. Help please


#1

I started having some saving issues last night, as described by others on the forum here – sadly I did not note the error code.

Anyway, on seeing the errors I sprung into action, knowing a colleague had lost a full day of work last week due to saving issues. I did a “Save As” and it appeared to work, so I went back to work, finishing up some designs until 2am, then bouncing a PDF for review and safekeeping, before saving one last time and shutting down.

This morning, the project files have none my work saved from that last stretch, so I’ve spent an additional couple hours redoing all the lost work from last night, based off the PDF. I’m now back to where I was at 2am, and I’m again noticing that neither Save nor Save As are creating or updating files at all. It would be great if I could avoiding having to do this work a 3rd time…

Any ideas guys? Anything I can do to help gather information about this state I’m in? Obviously, I’m scared to close the app because nothing is saved, and I’m frustrated with Balsamiq3, which seems to have lots of great new features, and some serious stability issues. IMO, you guys are on some VERY shaky ground with this auto-save feature.

Anyway, I was able to use the Export To Zip feature, but if I can help gather information about what’s happening, let me know. For now, I will just leave the app up and hope you guys can help me save this work.


#2

Had this problem when working on a sharepoint site…


#3

@CandyFactory, I’m so sorry to hear this is happening for you! We’re not hearing this from most people, so it would help us to find out more about your situation.

  • Which operating system are you on?
  • Which version are you using?
  • If it’s not 3.0.8, try updating and see if it helps: http://balsamiq.com/download.
  • Where are your files saved?
  • If it’s possible, try and make sure that you are working with files that are saved locally on your computer, and then sync them later

I’m sure we’ll get this figured out. Sorry for the hassle!


#4

Thanks Ben. I tried opening a new project and was able to save there. When I started to copy and paste the individual mockups over, saving in the new project broke too, so I suspect something is corrupt in the mockup?

I pasted the mockup that seems to break things into a text editor and can email it over if you want to take a look?

Im on Windows 8.1, running 3.0.3 – will update now, obviously. The files are saved to a local dropbox folder.


#5

That would be great if you could send that over to us. Just email support@balsamiq.com.

Unfortunately, (or in the case, I guess it’s fortunate!) 3.0.3 had some issues with saving. I think that things are going to be much better for you in the latest version. Let us know if you run into any trouble!

P.S. Just a heads up on Dropbox. Our app doesn’t work super well with it right now. If you are sharing that folder with other people, they are going to get notices of changes every time that you do something, because the file is being auto-saved. Also, if someone else works on the file at the same time, it will create a conflicted copy. We’re looking into way to handle this better in the future, but have a number of things we have to tackle first. Thanks!


#6

Just sent.

And thanks – things seem more stable with the update, and I was able to salvage the 2nd round of work by exporting and reimporting via ZIP file. I’ll take it :relieved:

I appreciate what you guys are trying to do, but I’ll just reiterate and echo what others in the forum have said – autosaving should be optional, and needs protections so that if something goes wrong the user is prompted to save.

Thanks Ben!


#7

I have been experiencing the same issues lately. First happened with the old Balsamiq Mockups and after I upgraded to Mockups 3, I thought the issues were gone - until today.

Had a very similar scenario to what CandyFactory described above. Half a day’s work just went poof!

When I create a new project and save it, everything works as expected. When I open an existing project, make changes, and save, Mockups tells me everything has been auto-saved. But when I look at the actual files on my computer, the save date is not updated. Interestingly, if I close the project, then open it again right away, my changes are still there. So the last time I had that issue I thought everything had been saved correctly - until this morning when I opened the project again after rebooting the computer, and all my changes were gone. Save As seems to work as long as I actually rename the project.

I am using Mockups 3.1.1 on Windows 7. At the moment, I save all my mockups directly to my OneDrive folder, so I’m suspecting that’s where the issue stems from. Will save them to my hard drive instead and see what happens.


#8

Sorry for the hassle @kat and do keep us posted. Also, I would suggest updating to 3.1.2, as we always fix bugs here and there: https://balsamiq.com/download to update.


#9

Thanks @peldi for the quick reply.

Update on my situation: I copied the project to my hard drive, opened it, and created a new mockup. Unfortunately, the issue persists: I cannot save my changes unless I choose “Save As” and rename the project :confused:

Update 2: “Save As” doesn’t work either unless I use a new name for the project. Save as one of the existing project files leads to the same result as normal Save, i.e. Mockups tells me everything has been autosaved, but the file on my hard drive is not updated, the date doesn’t change.


#10

I have recently switched computers, so I downloaded Mockups 3 after having Mockups 2 on my old machine. On both I’m using Windows 8.1 64-bit.

I am having this exact same issue now. I have Mockups 3.1.2 and I cannot get anything to save or export. I can’t get individual mockups to export nor can I get projects to save, save as, or export. This is very frustrating as I have three different projects I’m mocking up and I’m afraid to close out Balsamiq for losing what I have. I have had to screenshot each mockup, just in case.

Is there any resolution for this defect? I see that I have the most recent release (I bought my new machine only last week).