Slow to allow typing


#1

Apologies if this has been raised already.

Since upgrading to v3 a few months back, I’ve found that Balsamiq is too slow to focus a label or text object when double-clicking or hitting enter to edit it.

This means I have to wait before I type. Most times I don’t end up waiting long enough and my first keypress isn’t registered. This means either I miss the first letter of a sentence, or worse, if I was trying to go to the end of the selected text with the right arrow key, that isn’t registered, and I end up typing over the selected text. Does that make sense?

This was never an issue with v2, but happens constantly with v3.

Even if it does take a while to render the editable text, it should at least queue up your key presses. E.g. in Chrome if I use cmd+t to open a new tab then start typing a URL or search, even if the new tab hasn’t appeared yet, by the time it does all my keypresses have been correctly registered.

Currently using 3.1.2 on OS X.


#2

Hi @liamjohnston,

Sorry you’ve hit this snag.

We can’t seem to reproduce this issue so let’s try to see what is causing it on your end:

Could you please update to the latest version (3.2.4) to see if it helps? Here is the download page: https://balsamiq.com/download

Once you are on the latest version and if the issue persists, is this happening on a new project too?

If specific to one project, would you mind sending your BMPR file to support@balsamiq.com so that we can try to reproduce the issue here? We will keep your data in the strictest confidence and only long enough to try to debug your issue.

Sorry again for the hassle with this, we’ll get to the bottom of it!


#3

Thanks for the response.

I tried a brand new mockup where the only object is a single text element and the problem remains, so it appears to be an issue with the app itself, rather than how I am creating mockups.

Again, this never happened prior to v3. V2 must have either been snappy enough to go to ‘edit’ mode and select the text the instant I hit enter, or it was better at queueing up the keypresses like in the Chrome example (which other apps too).


#4

Hi @liamjohnston,

Thanks for the detailed informations.

Have you tried to update to the latest version (3.2.4)? https://balsamiq.com/download

If so, would you be available for a video-call so we can go through this together and try to solve the issue? I am based in Europe and usually available from 9 am to 5 pm (CET) but my colleague Brendan is based in the US if needed.
Please send us a mail to support@balsamiq.com with you preferred time and we’ll set it up.

Sorry again for the snag and thanks for your patience on this.