[SOLVED] Lost my work with no recovery option in Edge


#1

Hello,

I was working on my project in Microsoft Edge recently. Previously I was using Opera Beta while working on MyBalsamiq, but temporarily ditched it because of some issues with 100 tabs open & a lot of memory being eaten. While working on Edge, I noticed a few odd things such as many keyboard shortcuts not working. The project was always showing as “Saved” while I was doing the work. I had made about 3-4 mock pages in the morning in a project already having about 30 pages. Now in the night I’m opening the project, and those new mock pages I made in Edge just vanished!!!

I also tried opening the project in Opera, but Opera shows me some older auto-recovered mocks (which I didn’t save). Edge is showing me none of those auto-recovery options either. :cry: I can’t find any significant data which might point to some save-file in the localStorage of Edge either…


#2

Ugh, I’m really sorry about that @kumarharsh. Let’s see if we can recover those wireframes.

I’m going to have @Florian_Brauer go through the logs to see if we figure out what happened. Just to be sure, are you using the same computer/browser this evening that you used this morning? The autosave is local to the system that made the changes, meaning they wouldn’t be available on another computer.

And yeah, keyboard shortcuts in Edge are something we are still trying to tackle. I’m sorry about that as well, my friend.

Let me know about the computer, and I will have Florian take a look!


#3

Hi @Brendan - yes, I’m using the same computer. I tried to go through the localStorage, but couldn’t find any substantial data which might point to a recovery file…

Also, the Ctrl+S was saved in my muscle memory, so I just kept doing it even on Edge, even after observing the shortcuts were not working - for 2 straight hours. Talk about brain-fade :frowning2:. I just realized it when I went back to opera, and Ctrl+S actually showed a small notification to show that the file was actually saved. Something which I became accustomed to ignore over time. You can chalk that up to me being human :wink:. So, I guess the only bugs remaining are:

  1. Shortcuts don’t work in Edge
    1a. Also, Ctrl+G doesn’t work (at least) in Opera - it opens the browser’s search. Other shortcuts (Ctrl+C,Ctrl+V) work.
  2. Find and mercilessly exterminate this auto-recovery bug with Edge. :japanese_ogre:

#4

I’m so sorry about this, @kumarharsh. There is a fairly significant bug at play here, and we had no idea.

We did a lot of digging this morning, and it seems that Edge, Internet Explorer, and Firefox do not create autosave files (on Windows). When we pass them the data, it gets put into a folder that reflects the URL of the mockup, which causes problems. Chrome mitigates this by swapping characters out, but the other Windows browsers do not.

Needless to say, we are working on a fix for this right now, and I cannot apologize enough for losing your data because of it. I have added three months of credit to your myBalsamiq site. If there is anything else we can do, please don’t hesitate to ask.

Losing data is the worst thing software can do, and I’m sorry that that is exactly what ours did yesterday.


#5

Hey Brendan,

Woah, that’s a bad bug! I have seen some softwares on Windows such as flow who do this by replacing back slashes with ‘z’ creating weird-looking path-names which do the trick. Just a suggestion.

As for my work, well, my mocks became better after doing them the second time :wink:, so I guess it was good in a way.

I have added three months of credit to your myBalsamiq site.

Thank you for the gesture. I really appreciate your readiness to look into our feedback and the quick responses. Keep up the good work :slight_smile:


#6

We just pushed a myB release that should fix this bug. Cannot apologize enough for the folks it affected.

@kumarharsh let me know if you still see the issue on your side, my friend.


#7

@Brendan fantastic! It’s working on Edge now.