Balsamiq Community Discussion

Some links work and some don't in PDF export



I’m using myBalsamiq and when I “export to PDF” the links I inserted in my mockups do NOT work. Only some of them work. I can’t figure out what makes them work and what doesn’t. I checked for any broken links and there aren’t any.

My project has 31 screens and I can’t click through all of them :frowning: Is this is bug or am I doing something wrong?



Hey @elifares,

Sorry for all the trouble today, my friend.

There is currently a bug with myBalsamiq where links to mockups with spaces don’t work on exported PDFs. We have a fix for this in the pipeline and hope to release it early next week.

In the interim, if you need a working PDF before we release the fix, you can import your project into Mockups 3 for Desktop using these instructions.

I’m sorry again for all the myB trouble, Eli. We are hard at work at getting it all sorted.


Thanks for the quick reply @Brendan

I’m glad it’s a small issue like this, I can just rename all my slides and replace spaces with dashes then.
I don’t have Mockups 3 for Desktop.



I’m having the same issue in Desktop Mockups 3.5.4 on the Mac.

OK. 3.5.5 seems to fix the issue.


Hi I have the same issue when exporting to PDF, no links work…I have tried a test to rename a couple of wire frames to have no spaces in the wire frame name and they still don’t work in PDF. My current desktop version is 3.5.15 - 10-16-2017…




Sorry about that, Derek. Would it be possible to send us the file to and we can take a look?


actually it was because I was using adobe reader as opposed to “Acrobat Reader DC”, all is good now


The links in the exported PDF of my mockup work the first time I first open the PDF. But when I close the PDF and open again, some (not all ) links are broken. This occurs in Preview on mac, Adobe on mac and windows. No alternatives are in use. I am using Balsamiq Mockups 3.5.15.


Hmm, is it possible that links are overlapping, Gerry?

If you send the file to, we can take a look!


I don’t think they are. The first link on the first page is the only link on that page. I will send a file.


Thanks for sharing the file, @Gerry.

I’ll reply to your email now and we’ll take it from there if that works for you.


Sounds great :smiley:


Is there a fix. I have been sent a balsamic pdf mock-up and the links don’t work.


Hi @Jessica_Uresti,

Thanks for the post and sorry for the inconvenince here. Which platform are you on and which PDF reader are you using?

Would you mind asking the Balsamiq customer who sent you the PDF to reach out to us ( as we may need to take a closer look at the source project? Thank you!


Hi I am not sure if he has the time or if he would be able to share the file. I am going to download the trial version of Balsamiq and see if I can open his original file.


HI there! OK, @Jessica_Uresti - let us know what you need us to do. If you have the original .BMPR project file, we’d be happy to take a look with the permission of the owner/author. Only Balsamiq staff will see it, of course, and we’ll only keep it as long as we need for any diagnosis.

When you get a chance, let me know which PDF reader you are using, ok?


I tried Adobe Acrobat DC, Adobe Acrobat Reader and Mac Preview. Some links work on Mac Preview. None work on Adobe products. TY. I will let you know.