Stuck saving thumbnails


#1

Does anyone else run into issues where the app basically locks itself because it’s unable to auto-save the file>

I don’t even use the thumbnail view for my mockup list.

Because that first project is stuck my other open project is also failing to save

Both files are saved to a mapped network drive which remains accessible.


#2

Hi @Ryan,

Sorry for the trouble with this my friend!

I think that you’re already on the latest version (3.5.5), right?

It sounds like our autosave mechanism doesn’t play well with your network drive, unfortunately. This is one of the reasons we recently introduced the ability to switch to manual save when needed. Would you mind trying to disable the autosave to see if it helps?

Your changes will still be saved to the internal backup file, and they will automatically recover if you close Mockups without remembering to save.

Hopefully, this didn’t corrupt your file but in case it did, please look in those local backups as it should contain a working version of the file.

Hope this helps! Please let us know if this continues to bug you.


#3

Yes I had to kill the task this morning. The first project reopened ok but the second file completely disappeared so had to restore from local backup.


#4

Ugh, I’m really sorry about that @ryan, but I’m glad the local store had a good backup.

I would turn off autosave, and that should prevent this in the future. You are always saving to the local store, so even if you forget to save, we have your back. :slight_smile:

Really sorry again, my friend. Hopefully, turning off autosave will solve the issue for good.


#5

Same for me, it stuck on the first save, so I do not have any backup. Does it mean that I lost several hours of work?


#6

Hi @Marat and sorry for the trouble today.

Have you checked into the local backup folder yet?

If you are using a recent version (version 3.2.1 and above) of Mockups 3 for Desktop, there should be some backup files in there but please let us know if not.

Also, are you saving the file on a network drive by any chance?
If that is the case, I would try to disable the autosave to see if it helps to avoid the issue.

Sorry again for the snag, I’ll stand by for your reply and we’ll go from there.