Symbols cannot be copied between projects


#1

In the latest release I am now unable to complete the following workflow:

Steps:

  1. Copy an existing mock up (composed of symbols)
  2. Paste it into a blank project

Expected Result

  • Mock up is pasted and Symbol library is populated with the symbols used in that mock up

Actual Result

  • Mock up is pasted with lots of "symbol not founds

This is very frustrating, any chance that this could be resolved?


#2

Even if I copy/paste my symbol libraries to a new project, then paste the mock up in again it recognises some symbols and prompts to duplicate/replace but I am still left with a mock up full of “Symbol not found” boxes, despite the symbol library containing those symbols.


#3

Hi @Dan,

So sorry for the hassle with this.

Does the issue occur if you drag/drop the mockup from your existing project to a new one?

Would you mind sending your BMPR file to support@balsamiq.com so that we can try to reproduce the issue here? We will keep your data in the strictest confidence and only long enough to try to debug your issue.

Sorry again for the trouble, we’ll get to the bottom of it!


#4

Hi Virgin,

Unfortunately I will not be able to share.

Yes, drag and drop results in the same behaviour.


#5

I’ve tried to reproduce this by following your workflow but it worked as expected on my end, Dan.

I assume you are using our latest version (3.3.12), right?
Are you able to reproduce this in a new/example project you could share with us maybe?

Looking forward to help you more.


#6

Hi Virgin,

I sorry I have not had time to try this with a sample project but it is tripping me up constantly and sporadically. Sometimes it imports them, sometimes it doesn’t. Other times it detects the symbols exist already and prompts me but the result is often the same regardless of which option I select.

The only thing it does consistently is import the single ‘Asset’ I have and one of the symbol libraries (and always the same one never any others).

This is seriously affecting my ability to use this application.


#7

I’m really sorry for the trouble caused by this annoying bug, @Dan.

As I mentioned above, I suspect that the issue is specific to your BMPR file since we can’t reproduce the bug here, just tried again. Please let us know if you can share any sample project or feel free to send it directly to support@balsamiq.com, we want to do everything we can to get rid of it!