Things that are broken in the B3 Beta (Bugs!)


#1
  1. The application crashes when I open a project using the “Open Project…” command
  2. The PDF and PNG exports are empty (blank)
  3. When using the arrow keys to navigate from
    page to page, if something is selected on a page, the selection will start
    moving rather than navigation
  4. There is a pop-up with a tip or quote or something that appears every time I open the application. It disappears so quickly that I cannot tell what it is.

#2

Hi taelton

Thanks for jumping on the new version and special thanks for taking the time to report the issues you ran into.

  1. Does the crash happen always or with a particular project?

  2. I have seen this issue once but did not manage to reproduce the issue after a restart of the application. Does it happen for you reproducible? If so would you please share the steps with us? If it is with a particular project would you send it to us? (support@balsamiq.com)

  3. I reproduced the issue we get it fixed!

  4. We added UX quotes to all loading dialogs to make them more interesting. A part of me says great that the loading is so fast! The pop-ups have a link that opens the quote in your browser. just click somewhere on the quote to open the link.

I will let you know if I either manage to reproduce 2. or when 3. is fixed.


#3

Do you use by any chance Windows 10? Because there it is currently not possible to use the open menu.


#4

I would tag this little detail as a bug as well:

Tooltip says “Unroup” and not “Ungroup”:

:smile:


#5

Nice one! Fixed in build 999.917 (baking now). Thanks @sgiroux!


#6

Currently, new projects have “Use Sketch Skin” selected and “Use System Fonts” unchecked regardless of previously made choices. I’d expect Balsamiq to remember and respect my choices (v2 did that correctly).

Thanks.


#7

On Win8 the shortcut for showing the inspector (“CTRL+;”) won’t work.


#8

We changed those settings from being “per computer” to “per project”, so that when you share a BMPR, others see it the same way you did.

I have an idea on how to fix this: we could save the values on your computer as well, and look at those when creating new projects. This way new projects would “inherit” the same values as the previous project you saw. If all of your projects have the same value, you won’t have to change those manually.


#9

Yep, that would do the trick! Thanks again, @peldi


#10

Here is a little bug:

When I duplicate an item (Ctrl+D), next thing I do is move it downwards 20px by doing Shift+down. Unfortunately, it acts as if I did Ctrl+down and moves my duplicate to the back of the Z-order. Moving it in any other direction works fine.


#11

I have not experienced #1 or #2 lately, so let’s call these bugs resolved for now.


#12

Hi @Mathieu_Brault

Thank you for your report. I managed to reproduce the issue. It looks like the app reuses the CTRL value from the previous shortcut. We get it fixed.


#13

@Mathieu_Brault we fixed the issue in the latest version (999.18).


#14

Thanks a lot, keep’em coming.


#15

I have a set of about 100 mockups (created in Balsamiq v2). Nearly every mockup uses one asset. In this asset file I tried to add a canvas (Quick Add) which causes balsamiq to stop for a minute. Also every change seems to stop balsamiq for a while. I guess balsamiq updates every mockup in the background which costs a lot of time.
Maybe you can figure out something smart so I can still have my mockup open while I edit the asset!?


#16

In build 3.999.39 (friday morning), most of my icons are gone. I guess you are playing with Font Awesome but all the sketchy icons just disappeared from the bank!


#17

I can confirm this. All the previously imported custom assets are gone, too. They are still visible in Assets page (prefixed with “icon_”) but NOT visible under Assets tab in UI Library and on mockups.


#18

@Mathieu_Brault and @Taimar, you guys win the award for “quickest on the draw” for sure!

OK, so the news is that we replaced our icons with the FontAwesome set. I just checked it in, so there are bound to be bugs.

Existing icons should map to new icons…most of them are ok. What do you mean with “most of my icons are gone”? You should be able to see a FontAwesome equivalent of your old icon.

Regarding custom assets: we never showed custom icons in the Assets tab in the UI Library, they show under the Icons tab. Do you see them there?


#19

Left-FilledIn Triangle
Checkmark, Tick
Right-FilledIn Triangle, Play

Not only they don’t work anymore, it remains blank even if I manually try to select a new icon.


#20

I’m sorry but I still can’t make the bug happen. Here’s what I tried:

1.create a bmml with those 3 icons in 2.2
2.import it in B3 - the new icons show up

also

1.create a BMPR with those 3 icons in a build from yesterday
2.open that BMPR with the latest build

in both cases the new icons show up just fine.

What am I doing differently?