Unable to drag-drop/reorder mocks in left nav Mockups 3


#1

I am unable to drag and drop a mockup from the left nav bar around to place between other mockups. I’m on OS X El Capitan and Mockups 3. How can I rearrange the order of the mockups?


#2

Hey @arod, sounds like you have a weird one on your hands. Let’s see if we can figure out what’s going on.

This may be easier to troubleshoot over email, so feel free to send us an email at support@balsamiq.com, but there are couple things we can try now.

  • Are you on the most up-to-date version of Mockups 3 (3.3.6)?
  • Are you unable to re-order mockups in thumbnail mode? How about list mode? Both?
  • Are you able to drag controls from the UI library onto the canvas?

Let’s start there and see if we can get to the bottom of this. Sorry again for the trouble, but we will do everything we can to get it figured out! :slight_smile:


#3

Thanks, Brendan.

I’ll send an email but to answer your questions:

  • I am on the most up-to-date version 3.3.6
  • Unable to re-order in thumbnail and list modes
  • Unable to drag controls from the UI library – (double-clicking works)

#4

I have the same problem:

  • Version 3.3.6 - 01/15/2016 04:11
  • Adobe Air Player version: MAC 11,9,900,169
  • OSX El Capitan 10.11.3

#5

@jamie I’m sorry that you’re having this issue too, but maybe it gives us an opportunity to figure out what you two have in common that is causing Adobe Air to not cooperate with your machines.

Let me talk with the dev team on Monday (they are on EU time) and I will see if (assuming you and @arod are willing) we can set up a call to troubleshoot this together.

We have had one case of this in the past, and we weren’t able to resolve it with the information we had. We may have a second chance at that now.

I’ll post an update Monday morning, first thing


#6

Same issues, same symptoms. Unable to reorder mockups from either list or thumbnail view and cannot drag & drop from the UI library onto the canvas.

OSX Yosmite 10.10.5
Balsamiq Version 3.3.9
Adobe Air Version: MAC 11,9,900.169


#7

Hey @jamespcallaghan, I’m really sorry for this bug. We still aren’t sure what’s causing it.

I know it sounds crazy (and annoyingly “tier one tech support”-ish) but some folks have had success with rebooting their Mac. Something with Adobe Air gets gummed up and a reboot clears out the cobwebs.

Trust me, I wish there was a cooler potential solution, but folks in this thread have had success with it.

If that doesn’t work, shoot us an email at support@balsamiq.com and we will see if we can find the common thread between you and the other folks who are experiencing this.

I’m really sorry for the trouble. We want to get this one fixed very badly.


#8

Restart worked post updating Air (did not restart nor was prompted to restart after updating) thank you very much. Please let me know if I can be of assistance testing on this one, cheers!


#9

I’m having the same problem. I just updated to the latest version (Mac). This seems to be triggered specifically if I drag and drop a mockup from another open project. Once dragged over, the ability to drag to reorder mockups, in either text or thumbnail views, disappears from all open projects - the little “dots” don’t appear anymore. If I quit and restart Balsamiq, everything’s OK again.


#10

Oh interesting, @ajkandy. Are you able to reproduce that pretty reliably? Or is it sporadic?


#11

Yes, I reproduced it multiple times. Every time, dragging a mockup from one project window to another disables drag-reordering in ALL windows. Quitting and restarting the app fixes it.

Also, when dragging from one window to another, it looks like you can drag the mockup to a specific place in the target window’s list order - you get the little black line etc - but after the drag operation is completed, the dragged mockup will always end up at the bottom of the list.

I made a video screencap, can I send that to you via Dropbox?


#12

That would be super helpful, @ajkandy. You can send it to support@balsamiq.com or brendan@balsamiq.com - whichever you feel more comfortable with.

Thanks for taking the time to do that. We have yet been unable to reproduce it in house :frowning:


#13

I am having the same issue. I know this is an old topic, so I thought I would check to see if there is a solution or any new advice. I am not able to drag and drop to reorder mockups in the left nav, and I am not able to drag and drop from the UI library (double-clicking works). Thanks!


#14

Hi @John and sorry for the trouble with this one.

Are you running the most up-to-date version of Mockups 3 (3.5.7)?

Have you tried to restart the app and your machine by any chance?
I know it sounds like a very simple step but we’ve seen some good results trying it out. :slight_smile:

If the issue persists on your end, please let us know and we’ll dig deeper!


#15

Upgrading to 3.5.7 fixed my drag-drop issue. Thank you!!