Unable to install on windows


#1

Balsamiq 2 installs & runs without issue on my machine.
Balsamiq 3 will not install successfully.

I am installing this on a windows 7 machine I have for work. I have administrator rights for the machine.
For 3.0.4 I was able to get Balsamiq 3 to install when i right clicked the installer & used 'Run as Administrator". I ran into issues with 3.0.4 in that it would not open a project file, it would stop at the “Loading project” screen.

After downloading 3.0.5 the installer will not run at all. I download the installer, and open it either with double clicking or using the “Run as administrator” have no affect. I get the security dialog to allow the installer to modify windows, and then nothing happens after that. The installer exe then disappears from the download folder.

I can run Balsamiq 3 by using the adobe air bundled version & just running the exe. This works OK, but I would much rather have the application actually installed.


#2

Sorry for the hassle @minnaert. We’ll take a look and see what we can figure out. Thanks for taking the time to let us know. And I’m glad that you already found the workaround I was going to suggest! :slight_smile:


#3

Hi @minnaert,

Can you please check if you have the latest Adobe Air version installed?
I ask because the installer checks if you have Adobe Air installed. If you do it will check if you have a the latest. I have seen a case where Adobe Air tried to update itself but failed which then stopped our installer.

You can get the latest version of Adobe Air here:
https://get.adobe.com/air/

Please let us know if this resolves the issue.


#4

I checked my Adobe Air installation. I was up to date, no difference in behavior.
I uninstalled & reinstalled Air, no difference in behavior.
I still have the behavior of running the installer, nothing really happening, the the exe file disappears.


#5

With the 3.1.1 release, I was successfully able to install when i used the “Run as administrator” option. Not sure what the change was which caused this to work now, but it seems to be fixed.


#6

Hey everyone. yes I just wanted to confirm this also. When I try to install as administrator (or not) on my windows 7 machine I receive a startup dialog which shows a progress bar. The progress bar reaches the end and then the installation completely disappears and I cannot install. Based off this forum, I downloaded the adobe air combined zip installation and just opened up the mockups 3 exe which worked instantly.

The installer definitely seems broke for mockups 3.3 on windows 7.


#7

Hey @Matt_Ferguson!

Really sorry about the trouble with the installer. When you get a moment, would you shoot us an email to support@balsamiq.com?

We’d love to get to the bottom of this weird bug.


#8

Hey,

The Adobe AIR issue is a common one.Please include some instructions as I also faced this issue.After downloading and installing adobe AIR, the issue was resolved.

Thanks,


#9

Sorry about that @Sam37!

We are getting close to a permanent solution for this one since this issue came up again a short while ago. Be assured that this is the top priority on our to do list!

Thanks for the report! Please let us know if you need anything else.


#10

I’m having an install problem on Windows 7 as well. It appears the install is not putting Balsamiq in the correct location. After the installation appears to have installed successfully, when I try to run the program from the installation dialogue is says: Unable to execute file: C:\Program Files (x86)\Balsamiq Mockups 3\Balsamiq Mockups 3.exe

CreateProcess failed; code 267
The directory name is invalid.

I don’t think the installation is actually installing the program at all because the Balsamiq file does not exist in Program Files (x86) after a seemingly successful installation.


#11

Hi @Jason_Hollins!
Try installation-free version of the Balsamiq: download this ZIP and extract it anywhere.


#12

Thanks for the assist @Alexey_Kolchenko!

Jason reached out over email as well, and we think that the problem will be solved downloading and running this Microsoft tool.

If it doesn’t work, I will come back and update this thread :).