Unable to ungroup grouped mockup


#1

I recently completed a home page mockup and grouped all the elements of the page into one group, the entire page. I did this to reposition the mockup. However, I am no longer able to ungroup the page now.

Any ideas on how to fix this?


#2

Just realized that the mockup I was unable to ungroup had been I inadvertently converted to a symbol, which explains why my attempts at ungrouping failed. Don’t know how this happened, but it did.

Does anyone know a way to reverse this?


#3

Hi @pedrochristo!

You can convert back to a group by selecting the symbol and clicking “Break Apart” in the Symbol Properties panel. See image below.

Hope this helps! :smiley:


#4

Thanks Keith. I tried your suggestion and could not get it to "break apart."Community of Gardens - Home.bmpr (2.7 MB)

If you have a minute, I’ve uploaded the file so that you can see the problem…


#5

Hi @pedrochristo!

Seems like the items were grouped a multitude of times and in turn needed to be ungrouped a multitude of times :smile:

I ran a quick script to continuously ungroup until all the items were separate again, here’s a file with the items ungrouped. Let me know if you run into any other problems!

Community of Gardens - Home - ungrouped.bmpr (2.6 MB)

@peldi, should this be added as a bug, being able to group the same group of items multiple times?


#6

Great! Thanks for solving this problem. At one time suspected I had overdone the grouping and tried to ungroup a few times without success. Based on your success, I should have ungrouped many times more.

Again, thanks, it was very kind of you to help.

Peter


#7

You’re welcome @pedrochristo! Glad I could help!!


#8

I continue to have problems ungrouping, see attached item. Not sure if there’s some relationship between layering and grouping that’s preventing me from ungrouping successfully. I’ve done all the permutations forward back followed by over 50 ungroup commands and still I cannot ungroup. Keith was able to ungroup my earlier mockup running a ungrouping script. The attached element groups just 2 items, should ungroup with one command.Community of Gardens - Home.bmpr (2.7 MB)


#9

Hey @pedrochristo

I’m sorry that this continues to be a frustration for you. I managed to break apart your group, but it’s obvious that this is still an issue that we need to address. I am going to attach your original Mockup to the bug report so that our developers can see it.

Thank you for bringing this to our attention again. We will get it fixed :smile:

Community of Gardens - Home - Ungrouped.bmpr (2.7 MB)