Using Gallery in conjunction with Balsamiq in Confluence


#1

My team is using Balsamiq in the Confluence cloud. Absolutely love it! We figured out that we could add the Gallery macro and it would automatically display the Balsamiq pages. Unfortunately they’re not in the correct order. I’ve tried various things to get them to sort properly, even including renaming with a numeric prefix - ex. 010, 020, etc. - but nothing changed the order they’re displayed.

Has anyone discovered a way to resolve this?

Robert


#2

Hey Robert!

I played around with this a little bit, and I think I have an answer for you.

When Mockups 3 for Confluence Cloud exports PNGs (and attaches them to the Confluence Page) it doesn’t name them after the mockups. It gives them random names to ensure they don’t conflict with existing attachments.

Instead, it puts the mockup name in the comment column.

If you sort your gallery by comments, it should put the mockups in order. Give that a shot and let me know if that works better.

Sorry for any hassle this has caused you, my friend.


#3

Thanks for the suggestion, Brendan. I just tried as you suggested, sorting
by comments. I gave the first two pages in my Balsamiq project the
prefixes “010” and “020” respectively; all the rest begin with letters.
When I edited Gallery to sort by comments it didn’t place these two first.
So I deleted the Gallery macro and added a new one. Same problem.

I even went one step further and explicitly added comments - “010” to the
first page, “020” to the second page, etc. but that didn’t change anything
either.

It almost seems like the images are cached in a specific order and one is
stuck with that.


#4

Sorry about that, Robert. I think what is happening is maybe the new pages aren’t being exported on exit because the plugin doesn’t realize that the pages are different.

Would you mind making small changes to the mockups themselves on the ones you renamed? That will force the editor to export them again, and hopefully give us the right name.

I wasn’t clear enough before, and I’m sorry about that, but the comments I was talking about were the Confluence comments, not the comments on the mockups themselves.

Let me know if that works, Robert. If not, we will dig deeper :slight_smile:


#5

Just so I’m clear, I’ve actually tried both approaches:

  1. Renaming the mockups themselves, prefixing them with “010”, “020”, …
  2. Adding numerically sequential comments.

Neither approach had any effect.


#6

Ahh, gotcha Robert.

When you look at those mockup PNGs in the attachments, do the comments there reflect the new 010-020 naming scheme? If not, we may have to make a small change in them to force them to re-export.


#7

They do not. In fact, two of them use very old names: “New Mockup 1” and
"New Mockup 2" I’ve long since renamed those but for some reasons Gallery
is not picking up the latest names from Balsamiq.

It is most mysterious to me why, when I add a brand new Gallery macro, the
page names would not be the most recent.

I’m assuming you could test this all for yourself in Confluence?


#8

Oh this isn’t the Gallery’s fault. This is Mockups’ saving the PNGs with the old file names. I’m going to file a bug with that.

Let’s try this:

Delete the PNGs attachments that have the comment “Balsamiq generated, do not remove”. That won’t delete the actual mockup, which is the .BMPR file.

Then, edit the mockup again (you can do this by clicking Edit, double clicking on the smiley face, and then “Open Mockups Editor.”

Once you’re in the editor again, click Project > Export > All Mockups to PNG. When that completes, choose the “Attach to Confluence” option.

That will get us fresh images, and hopefully allow the gallery to order them correctly.


#9

Brendan,

In Confluence there is no way to delete the PNGs on a page.

I’ll wait for your team to fix the issues and will be happy to test that
new version for you!

Robert


#10

Hey Robert, I think I may be a misunderstanding here. Maybe it would be easier to jump into a video call and walk through this.

You should be able to delete attachments for pages you have created. In the attachments menu, there should be a Delete link:

Do you see something different? Let me know!


#11

I don’t have Delete privileges. I’ve requested them from our Confluence
administrator.