Zoom to fit does not consider scrollbars


#1

Hey guys, ever since I used the Balsamiq Confluence plugin I had this problem:
When I zoom a wireframe to fit (either the current one or all), Balsamiq ignores the space taken by the horizontal and vertical scrollbars, meaning the Wireframe will be only almost zoomed to fit the current view.

Here is an image of the problem (here the wireframe is hidden behind the vertical scrollbar):

It is only my assumption that the scrollbars are the reason, might be something else as well.

I found the bug on Mac with Firefox and Safari.

Could the problem be that I have scrollbars always enabled on Mac (as is described here)?


#2

Sorry for the trouble with this @bhaering. You are exactly right because the scrollbars are enabled all the time, the app removes them from the available space.

If you set your scroll bars to hide, I would bet that zoom to fit will work more like you’re expecting.

I’m not sure there is anything we can do here, unfortunately. The browsers (and, by extension, macOS) is telling the Confluence addon what the available space is.

Let me know if hiding the scrollbars allows the controls to zoom correctly. If not, we will definitely dig deeper.


#3

You are right, when the scrollbars are set to be hidden the problem is gone.

I should have tested it before I wrote here, but somehow I only realised that this might be the reason for the problem while typing it. Thank you for your help.


#4

I’m just glad you found the answer. :slight_smile:

Don’t ever hesitate to get in touch if you run into trouble @bhaering. This was something I didn’t know was an issue until you asked! Even if though you figured it out, the information was still super useful to us - thank you for posting it. :slight_smile: